build: Require yasm 0.8.0 or higher