pgssubdec: fix API compability layer