doc/libav_merge: remove line about ADVANCED_PARSER