hlsenc: Fix the openssl support