matroskadec: move ARRAY_SIZE() macro at top of the file
[ffmpeg.git] / libavfilter /
2008-05-26 Diego Biurrunconsistency cosmetics: indices --> indexes
2008-05-24 Vitor SessakSplit openLinks linked list into openInputs and openOutputs
2008-05-24 Vitor SessakOne more memory leak
2008-05-24 Vitor SessakCosmetical: move statement
2008-05-24 Vitor SessakPlug some memory leaks
2008-05-24 Vitor SessakMerge variable initialization and declaration
2008-05-24 Vitor SessakCosmetics
2008-05-24 Vitor SessakRemove unnused var
2008-05-24 Vitor SessakSimplify
2008-05-24 Vitor SessakUse av_mallocz instead of av_malloc to simplify some...
2008-05-24 Vitor SessakFactor linked list insertion in its own function
2008-05-24 Vitor SessakRemove comment redundant with those in graphparser.h
2008-05-24 Vitor SessakThese error messages should print the filter name,...
2008-05-24 Vitor Sessak10l: fix previous commit
2008-05-24 Vitor SessakSimplify
2008-05-24 Vitor SessakRemove senseless comments
2008-05-24 Vitor SessakCosmetics: split setting a var and checking for error
2008-05-24 Vitor SessakFix doxy comment
2008-05-24 Vitor SessakMake parse_link_name() return a pointer to the name...
2008-05-24 Vitor SessakCosmetics: more function reordering
2008-05-24 Vitor SessakMake consume_whitespace() return a number of bytes...
2008-05-24 Vitor SessakCosmetics: change function order
2008-05-24 Vitor SessakSimplify
2008-05-24 Vitor SessakPass the inputs and outputs of avfilter_parse_graph...
2008-05-24 Vitor SessakCosmetics: more indentation consistency
2008-05-24 Vitor SessakMore cosmetics: make indentation more consistent
2008-05-24 Vitor SessakMore cosmetics
2008-05-24 Vitor SessakMove code out of if
2008-05-24 Vitor SessakCosmetics
2008-05-24 Vitor SessakCosmetics
2008-05-24 Vitor SessakFactor common code out of if
2008-05-24 Vitor SessakRename another var
2008-05-24 Vitor SessakRename var
2008-05-24 Vitor SessakMove var declaration to where it is needed
2008-05-24 Vitor SessakReplace if(!a){B}else{C} by if(a){C}else{B}
2008-05-24 Vitor SessakRemove useless assignment
2008-05-24 Vitor SessakSimplify while(pad){pad--; etc} to while(pad--){etc}
2008-05-24 Vitor SessakSimplify extract_inout() as suggested by Michael
2008-05-24 Vitor SessakChange the parser logic following Michael's review
2008-05-24 Vitor SessakThe name field of AVFilterInOut can be declared const
2008-05-24 Vitor SessakA semi-colon is also a string end
2008-05-24 Vitor Sessak10l: Missed that in one of the last commits
2008-05-24 Vitor SessakMove code from handle_link() to the only place the...
2008-05-24 Vitor SessakSimplify
2008-05-24 Vitor SessakUse a user-provided context for av_log()
2008-05-24 Vitor SessakImprove error handling
2008-05-24 Vitor SessakCosmetics
2008-05-24 Vitor SessakBetter error handling
2008-05-24 Vitor SessakSimplify
2008-05-24 Vitor SessakLink filters in the same pass as the parser
2008-05-24 Vitor SessakCosmetics: if(x != NULL) -> if(x)
2008-05-24 Vitor SessakEven more improvements on whitespaces handling
2008-05-24 Vitor SessakMore improvements on the handling of whitespaces
2008-05-24 Vitor SessakProper handling of trailing whitespaces
2008-05-24 Vitor SessakRemove unneeded var
2008-05-24 Vitor SessakCosmetics: alignment
2008-05-24 Vitor SessakMake two variables const
2008-05-24 Vitor SessakBetter error messages
2008-05-24 Vitor SessakMore simplifying
2008-05-24 Vitor SessakSimplify
2008-05-24 Vitor SessakMerge declaration and initialization
2008-05-24 Vitor SessakCosmetics
2008-05-24 Vitor SessakUpdate comments to new syntax
2008-05-24 Vitor Sessak10l: Forgot to consider the null byte at the end of...
2008-05-24 Vitor SessakUse '[' and ']' for label naming
2008-05-24 Vitor SessakRename avfilter_graph_parse_chain() to avfilter_parse_g...
2008-05-24 Vitor SessakRename AVFilterInOut.instance to AVFilterInOut.filter
2008-05-24 Vitor SessakCosmetics
2008-05-24 Vitor SessakSimplify consume_string() as Michael suggested
2008-05-24 Vitor SessakSimplify
2008-05-24 Vitor SessakBetter instance name for parsed filters
2008-05-24 Vitor SessakUse link_filter() instead avfilter_link() when clearer
2008-05-24 Vitor SessakAvoid searching by instance name when it is not necessary
2008-05-24 Vitor SessakBetter error messages
2008-05-24 Vitor SessakHandle av_realloc() failure
2008-05-24 Vitor SessakLast commit was missing header file
2008-05-24 Vitor SessakI should not have merged the graph parser with the...
2008-05-09 Diego BiurrunUse full path for #includes from another directory.
2008-04-07 Måns Rullgårdnon-recursive makefiles
2008-04-04 Vitor SessakHandle av_realloc() failure
2008-04-04 Vitor SessakUse sizeof(var) instead of sizeof(type)
2008-04-04 Vitor SessakGive a more meaningful instance name to auto-inserted...
2008-04-04 Vitor SessakMerge two ifs
2008-04-04 Vitor SessakRemove unused check
2008-04-04 Vitor SessakCosmetical: alignment
2008-04-04 Vitor SessakRemove some unwanted todos
2008-04-04 Vitor SessakRemove declaration of nonexisting function
2008-04-04 Vitor SessakI should not have merged the graph parser with the...
2008-04-04 Vitor SessakReplace consume_char() function by *(*buf)++
2008-04-04 Vitor SessakAdd backslash '\' support to the parser
2008-04-04 Vitor SessakRemove AVFilterGraphDesc struct.
2008-04-04 Vitor SessakRename uninit() to avfilter_destroy_graph() and make...
2008-04-04 Vitor SessakRename functions now static
2008-04-04 Vitor SessakMove funtion to avoid forward declaration
2008-04-04 Vitor SessakMove mess (to be removed) to where it is actually used.
2008-04-04 Vitor SessakRemove usage of AVFilterGraphDesc outside avfiltergraph.c
2008-04-04 Vitor SessakSimplify graph_load_from_desc3()
2008-04-04 Vitor SessakRename variable GraphContext -> AVFilterGraph
2008-04-04 Vitor SessakMerge avfiltergraphdesc.c in avfiltergraph.c
2008-04-04 Vitor SessakRemove avfilter_vf_graph
next