Doxy comment
[ffmpeg.git] / libavcodec / ra144.c
2008-06-29 Vitor SessakDoxy comment
2008-06-24 Vitor SessakSimplify interp()
2008-06-24 Vitor SessakMore cosmetics
2008-06-24 Vitor SessakCosmetics
2008-06-24 Vitor SessakUse lpc_coef[2] instead of lpc_coef and lpc_coef_old
2008-06-24 Vitor SessakRemove unused entries from lpc_refl_cb*
2008-06-24 Vitor SessakRemove unused entries from energy_tab
2008-06-23 Vitor SessakMerge the >> 4 calculation of cb1_base in the table
2008-06-23 Vitor SessakConsistency: make the output buffer the first argument...
2008-06-23 Vitor SessakUse sizeof() intead of hardcoding the values
2008-06-23 Vitor SessakSimplify
2008-06-23 Vitor SessakSimplify
2008-06-23 Vitor SessakIt makes more sense to return 1 here in case of overflow.
2008-06-23 Vitor SessakCosmetics: indent
2008-06-23 Vitor SessakRemove unneeded check
2008-06-23 Vitor Sessakrescale_rms() should use unsigned ints
2008-06-23 Vitor SessakMove factor multiplication out of irms()
2008-06-23 Vitor SessakThis should be signed
2008-06-23 Vitor SessakMore comments removal/fixes
2008-06-23 Vitor SessakRemove useless comment
2008-06-23 Vitor SessakMore comments improvement
2008-06-23 Vitor SessakDocument defines better
2008-06-23 Vitor SessakRemove useless define
2008-06-23 Vitor SessakRename rotate_buffer() to copy_and_dup() and doxy it
2008-06-23 Vitor SessakSimplify t_sqrt()
2008-06-23 Vitor SessakAdd doxy comment
2008-06-23 Vitor SessakRename var
2008-06-23 Vitor SessakMove code unrelated to lpc filtering out of lpc_filter()
2008-06-23 Vitor SessakSimplify rotate_buffer()
2008-06-22 Vitor SessakCosmetics
2008-06-22 Vitor SessakAvoid a memcpy. Code is also simpler now in my opinion.
2008-06-20 Vitor SessakDo not write junk in the end of truncated files. FATE
2008-06-19 Vitor SessakMisc cosmetics
2008-06-19 Vitor SessakRemove useless comment
2008-06-19 Vitor SessakLast table renaming
2008-06-19 Vitor SessakYet more table renaming
2008-06-19 Vitor SessakMore table renaming
2008-06-19 Vitor SessakRename table
2008-06-19 Vitor SessakRename vars: s/decsp/out/
2008-06-19 Vitor SessakRename function
2008-06-19 Vitor SessakRename var
2008-06-12 Stefano SabatiniMake AVCodec long_names definition conditional dependin...
2008-06-05 Vitor SessakRemove *lpc_refl from the context. Only the value
2008-06-05 Vitor SessakSplit function rms() in two (it does two unrelated...
2008-06-02 Vitor SessakRemove warning that could never be triggered.
2008-06-01 Vitor SessakReplace comments by error messages.
2008-06-01 Vitor SessakCosmetics
2008-06-01 Vitor SessakRename dec2() function
2008-06-01 Vitor SessakRename var
2008-06-01 Vitor SessakRename dec1() to a more descriptive name
2008-06-01 Vitor SessakThe function dec1() do two completly unrelated things...
2008-06-01 Vitor SessakYet more variable renaming
2008-06-01 Vitor SessakMore variable renaming
2008-06-01 Vitor SessakRename functions
2008-06-01 Vitor SessakRename variables
2008-05-31 Vitor SessakAdd doxy comments to eq() and do_voice()
2008-05-31 Vitor SessakMinor simplification
2008-05-31 Vitor SessakRename variable
2008-05-31 Vitor SessakRemove useless intermediate variable
2008-05-30 Vitor SessakRevert r13499, log:
2008-05-28 Vitor SessakRename variable
2008-05-28 Vitor SessakMore intermediate vars removal
2008-05-28 Vitor SessakRemove unused var
2008-05-28 Vitor SessakRemove useless intermediate var
2008-05-28 Vitor SessakRemove dec1() function
2008-05-28 Vitor SessakUse ff_acelp_weighted_vector_sum() instead of reimpleme...
2008-05-28 Vitor SessakMake lpc coefficients 16 bit wide
2008-05-28 Vitor SessakSimplify implementation and use of dec2()
2008-05-27 Vitor SessakAdd comment
2008-05-27 Vitor SessakFix doxy comments
2008-05-27 Diego Biurruncosmetics: typo fixes
2008-05-26 Diego Biurruncosmetics: typo
2008-05-26 Vitor SessakRename var: add read coefficients a decent name
2008-05-26 Vitor SessakUpdate comment
2008-05-26 Vitor SessakRename var: val -> energy
2008-05-26 Vitor SessakRename var: swapbuf* are LPC related
2008-05-26 Vitor SessakRename var: buffer_2 is an adaptive codebook
2008-05-26 Vitor SessakContext vars are not global vars. glob is a bad name...
2008-05-26 Vitor SessakRename context struct to be more consistent with the...
2008-05-25 Vitor SessakMerge two if's
2008-05-25 Vitor SessakUse (u)int16_t instead of (unsigned) short
2008-05-25 Vitor SessakMore cosmetics
2008-05-25 Vitor SessakCosmetics
2008-05-25 Vitor SessakRename var
2008-05-25 Vitor SessakMinor simplification of dec1()
2008-05-25 Vitor SessakMinor simplification of dec2()
2008-05-25 Vitor SessakRemove useless variable
2008-05-25 Vitor SessakCosmetics: merge declaration and initialization
2008-05-25 Vitor SessakCosmetics: braces removal
2008-05-25 Vitor SessakMove evaluation of variable a to where it is trivial
2008-05-25 Vitor SessakMake add_wav() receive a vector instead of three integers
2008-05-25 Vitor SessakRemove gbuf2 from context
2008-05-25 Vitor SessakUse (u)int16_t instead of short for tables
2008-05-25 Vitor SessakMake tables that fit in one byte (u)int8_t
2008-05-25 Vitor SessakRemove yet another val (gbuf1) from context
2008-05-25 Vitor SessakParameter n of dec functions is always 3. Hardcode it.
2008-05-24 Vitor SessakIndent
2008-05-24 Vitor SessakRemove another useless variable from context
2008-05-24 Vitor SessakUse an intermediate variable for overflow testing
2008-05-24 Vitor SessakHandle the case where we do not have enough input
next