tools/patcheck: remove gcc-2.95 compat check
authorJames Zern <jzern@google.com>
Fri, 20 Sep 2019 07:04:06 +0000 (00:04 -0700)
committerJames Zern <jzern@google.com>
Sat, 21 Sep 2019 19:57:04 +0000 (12:57 -0700)
this conflicts with the current contributing guidance:
http://ffmpeg.org/developer.html#Contributing
FFmpeg is programmed in the ISO C90 language with a few additional
features from ISO C99, namely:
...
for loops with variable definition (‘for (int i = 0; i < 8; i++)’);

Signed-off-by: James Zern <jzern@google.com>
tools/patcheck

index 101a542..fe52938 100755 (executable)
@@ -50,7 +50,6 @@ hiegrep ';;'              'double ;' $*
 hiegrep2 '\b_[a-zA-Z0-9_]{1,}' '__(asm|attribute)([^a-zA-Z0-9]|$)' 'reserved identifer' $*
 hiegrep '//[-/<\* ]*$'    'empty comment' $*
 hiegrep '/\*[-<\* ]*\*/'  'empty comment' $*
-hiegrep 'for *\( *'"$ERE_PRITYP"' '  'not gcc 2.95 compatible' $*
 hiegrep '(static|inline|const) *\1[^_a-zA-Z]'  'duplicate word' $*
 hiegrep 'INIT_VLC_USE_STATIC' 'forbidden ancient vlc type' $*
 hiegrep '=[-+\*\&] ' 'looks like compound assignment' $*