Use AV_GCC_VERSION_AT_LEAST instead of complicated __GNUC__ version check.
authorDiego Biurrun <diego@biurrun.de>
Tue, 10 Feb 2009 01:24:06 +0000 (01:24 +0000)
committerDiego Biurrun <diego@biurrun.de>
Tue, 10 Feb 2009 01:24:06 +0000 (01:24 +0000)
Originally committed as revision 17114 to svn://svn.ffmpeg.org/ffmpeg/trunk

libavutil/common.h

index 6887cf0..506c68f 100644 (file)
@@ -78,7 +78,7 @@
 #endif
 
 #ifndef av_flatten
-#if defined(__GNUC__) && (__GNUC__ > 4 || __GNUC__ == 4 && __GNUC_MINOR__ > 0)
+#if AV_GCC_VERSION_AT_LEAST(4,1)
 #    define av_flatten __attribute__((flatten))
 #else
 #    define av_flatten