Merge commit '52a1c32c0a86e84d43f977c5148e62975a0c6917'
authorMichael Niedermayer <michaelni@gmx.at>
Tue, 8 Jul 2014 19:08:01 +0000 (21:08 +0200)
committerMichael Niedermayer <michaelni@gmx.at>
Tue, 8 Jul 2014 19:18:36 +0000 (21:18 +0200)
* commit '52a1c32c0a86e84d43f977c5148e62975a0c6917':
  nut: Use nut->version in the version range check

Conflicts:
libavformat/nutdec.c

Note, this bug did not affect ffmpeg
Merged-by: Michael Niedermayer <michaelni@gmx.at>
1  2 
libavformat/nutdec.c

@@@ -229,15 -213,13 +229,15 @@@ static int decode_main_header(NUTContex
      end  = get_packetheader(nut, bc, 1, MAIN_STARTCODE);
      end += avio_tell(bc);
  
-     tmp = ffio_read_varlen(bc);
-     if (tmp < NUT_MIN_VERSION && tmp > NUT_MAX_VERSION) {
-         av_log(s, AV_LOG_ERROR, "Version %"PRId64" not supported.\n",
-                tmp);
+     nut->version = ffio_read_varlen(bc);
+     if (nut->version < NUT_MIN_VERSION &&
+         nut->version > NUT_MAX_VERSION) {
+         av_log(s, AV_LOG_ERROR, "Version %d not supported.\n",
+                nut->version);
          return AVERROR(ENOSYS);
      }
-     nut->version = tmp;
 +    if (nut->version > 3)
 +        nut->minor_version = ffio_read_varlen(bc);
  
      GET_V(stream_count, tmp > 0 && tmp <= NUT_MAX_STREAMS);