Disable symbol versioning on some BSDs
authorMans Rullgard <mans@mansr.com>
Sun, 23 Jan 2011 20:48:51 +0000 (20:48 +0000)
committerMans Rullgard <mans@mansr.com>
Sun, 23 Jan 2011 21:33:31 +0000 (21:33 +0000)
Dragonfly, NetBSD, and OpenBSD do not support symbol versioning
although our link test passes.  Disable it explicitly for these
systems.

Signed-off-by: Mans Rullgard <mans@mansr.com>
configure

index 63eadca..4c24152 100755 (executable)
--- a/configure
+++ b/configure
@@ -2306,6 +2306,7 @@ case $target_os in
         nm_opts='-P -g'
         ;;
     netbsd)
+        disable symver
         oss_indev_extralibs="-lossaudio"
         oss_outdev_extralibs="-lossaudio"
         add_cppflags -D_XOPEN_SOURCE=600
@@ -2318,11 +2319,16 @@ case $target_os in
         # (simply quits with exit-code 1, no crash, no output).
         # Thus explicitly enable PIC here.
         enable pic
+        disable symver
         SHFLAGS='-shared'
         oss_indev_extralibs="-lossaudio"
         oss_outdev_extralibs="-lossaudio"
         ;;
-    freebsd|dragonfly)
+    dragonfly)
+        enable malloc_aligned
+        disable symver
+        ;;
+    freebsd)
         enable malloc_aligned
         ;;
     bsd/os)