build: Require yasm 0.8.0 or higher
authorDerek Buitenhuis <derek.buitenhuis@gmail.com>
Mon, 7 Oct 2013 11:18:54 +0000 (07:18 -0400)
committerDerek Buitenhuis <derek.buitenhuis@gmail.com>
Wed, 9 Oct 2013 11:44:19 +0000 (07:44 -0400)
This is in preparation for removing a .rodata kludge
which was only required for older YASM versions.

The movbe instruction was introduced in 0.8.0, which already
had AVX, which was introduced in 0.7.0, and NASM introduced
movbe in 2.0.3, which is the same version which introduced
AVX support.

Also, make the failure message more accurate.

Signed-off-by: Derek Buitenhuis <derek.buitenhuis@gmail.com>
configure

index 167f4ee..7e52abf 100755 (executable)
--- a/configure
+++ b/configure
@@ -3591,8 +3591,8 @@ EOF
             elf*) enabled debug && append YASMFLAGS $yasm_debug ;;
         esac
 
-        check_yasm "vextractf128 xmm0, ymm0, 0" && enable yasm ||
-            die "yasm not found, use --disable-yasm for a crippled build"
+        check_yasm "movbe ecx, [5]" && enable yasm ||
+            die "yasm/nasm not found or too old. Use --disable-yasm for a crippled build."
         check_yasm "vfmaddps ymm0, ymm1, ymm2, ymm3" || disable fma4_external
         check_yasm "CPU amdnop" && enable cpunop
     fi