avformat/nutenc: fix used version value
authorMichael Niedermayer <michaelni@gmx.at>
Wed, 28 May 2014 23:37:46 +0000 (01:37 +0200)
committerMichael Niedermayer <michaelni@gmx.at>
Wed, 28 May 2014 23:40:07 +0000 (01:40 +0200)
The broadcast/pipe flags arent stable + 1 they would be 4 or whenever but wouldnt change based
on which is stable

Signed-off-by: Michael Niedermayer <michaelni@gmx.at>
libavformat/nutenc.c

index 237b501..fd245ea 100644 (file)
@@ -697,7 +697,7 @@ static int nut_write_header(AVFormatContext *s)
 
     nut->avf = s;
 
-    nut->version = NUT_STABLE_VERSION + !!nut->flags;
+    nut->version = FFMAX(NUT_STABLE_VERSION, 3 + !!nut->flags);
     if (nut->flags && s->strict_std_compliance > FF_COMPLIANCE_EXPERIMENTAL) {
         av_log(s, AV_LOG_ERROR,
                "The additional syncpoint modes require version %d, "