libcelt: configure: distinguish not found and too old.
authorNicolas George <nicolas.george@normalesup.org>
Tue, 24 Jan 2012 12:21:34 +0000 (13:21 +0100)
committerNicolas George <nicolas.george@normalesup.org>
Tue, 24 Jan 2012 12:23:02 +0000 (13:23 +0100)
Fixes ticket #940.

configure

index a06e63c..2a3975e 100755 (executable)
--- a/configure
+++ b/configure
@@ -3110,7 +3110,9 @@ enabled frei0r     && { check_header frei0r.h || die "ERROR: frei0r.h header not
 enabled gnutls     && require_pkg_config gnutls gnutls/gnutls.h gnutls_global_init
 enabled libaacplus && require  "libaacplus >= 2.0.0" aacplus.h aacplusEncOpen -laacplus
 enabled libass     && require_pkg_config libass ass/ass.h ass_library_init
-enabled libcelt    && require libcelt celt/celt.h celt_decoder_create_custom -lcelt0
+enabled libcelt    && require libcelt celt/celt.h celt_decode -lcelt0 &&
+                      { check_lib celt/celt.h celt_decoder_create_custom -lcelt0 ||
+                        die "ERROR: libcelt version must be >= 0.11.0."; }
 enabled libdc1394  && require_pkg_config libdc1394-2 dc1394/dc1394.h dc1394_new
 enabled libdirac   && require_pkg_config dirac                          \
     "libdirac_decoder/dirac_parser.h libdirac_encoder/dirac_encoder.h"  \