configure: NVENC API version 6 is now required
authorTimo Rothenpieler <timo@rothenpieler.org>
Fri, 4 Mar 2016 16:19:45 +0000 (17:19 +0100)
committerTimo Rothenpieler <timo@rothenpieler.org>
Fri, 4 Mar 2016 22:03:14 +0000 (23:03 +0100)
configure

index 81769ee..9b56a4d 100755 (executable)
--- a/configure
+++ b/configure
@@ -5681,8 +5681,8 @@ enabled mmal &&
 
 enabled netcdf            && require_pkg_config netcdf netcdf.h nc_inq_libvers
 enabled nvenc             && { check_header nvEncodeAPI.h || die "ERROR: nvEncodeAPI.h not found."; } &&
-                             { check_cpp_condition nvEncodeAPI.h "NVENCAPI_MAJOR_VERSION >= 5" ||
-                               die "ERROR: NVENC API version 4 or older is not supported"; } &&
+                             { check_cpp_condition nvEncodeAPI.h "NVENCAPI_MAJOR_VERSION >= 6" ||
+                               die "ERROR: NVENC API version 5 or older is not supported"; } &&
                              { [ $target_os != cygwin ] || die "ERROR: NVENC is not supported on Cygwin currently."; }
 enabled openal            && { { for al_libs in "${OPENAL_LIBS}" "-lopenal" "-lOpenAL32"; do
                                check_lib 'AL/al.h' alGetError "${al_libs}" && break; done } ||