Merge remote-tracking branch 'newdev/master'
authorMichael Niedermayer <michaelni@gmx.at>
Sat, 19 Mar 2011 19:02:42 +0000 (20:02 +0100)
committerMichael Niedermayer <michaelni@gmx.at>
Sat, 19 Mar 2011 19:05:11 +0000 (20:05 +0100)
Merged-by: Michael Niedermayer <michaelni@gmx.at>
Not Pulled:
    commit 42cfb3835b5dad327b7dc22740e8b6e482ecfcd2
    Author: Mans Rullgard <mans@mansr.com>
    Date:   Mon Feb 28 18:06:58 2011 +0000

        Remove Sonic experimental audio codec

    commit 2912e87a6c9264d556734e2bf94a99c64cf9b102
    Author: Mans Rullgard <mans@mansr.com>
    Date:   Fri Mar 18 17:35:10 2011 +0000

        Replace FFmpeg with Libav in licence headers

1  2 
Doxyfile
Makefile
configure
doc/developer.texi
doc/faq.texi
doc/general.texi
libpostproc/postprocess.c
version.sh

diff --cc Doxyfile
Simple merge
diff --cc Makefile
Simple merge
diff --cc configure
Simple merge
@@@ -74,9 -74,9 +74,9 @@@ Indent size is 4
  The presentation is one inspired by 'indent -i4 -kr -nut'.
  The TAB character is forbidden outside of Makefiles as is any
  form of trailing whitespace. Commits containing either will be
- rejected by the Subversion repository.
+ rejected by the git repository.
  
 -The main priority in Libav is simplicity and small code size in order to
 +The main priority in FFmpeg is simplicity and small code size in order to
  minimize the bug count.
  
  Comments: Use the JavaDoc/Doxygen
diff --cc doc/faq.texi
@@@ -20,16 -20,16 +20,16 @@@ bugs and reviewing patches takes preced
  request more timely and/or frequent releases unless you are willing to
  help out creating them.
  
 -@section I have a problem with an old version of Libav; where should I report it?
 -Nowhere. We do not support old Libav versions in any way, we simply lack
 +@section I have a problem with an old version of FFmpeg; where should I report it?
 +Nowhere. We do not support old FFmpeg versions in any way, we simply lack
  the time, motivation and manpower to do so. If you have a problem with an
- old version of FFmpeg, upgrade to the latest Subversion snapshot. If you
 -old version of Libav, upgrade to the latest git snapshot. If you
++old version of FFmpeg, upgrade to the latest git snapshot. If you
  still experience the problem, then you can report it according to the
 -guidelines in @url{http://libav.org/bugreports.html}.
 +guidelines in @url{http://ffmpeg.org/bugreports.html}.
  
 -@section Why doesn't Libav support feature [xyz]?
 +@section Why doesn't FFmpeg support feature [xyz]?
  
 -Because no one has taken on that task yet. Libav development is
 +Because no one has taken on that task yet. FFmpeg development is
  driven by the tasks that are important to the individual developers.
  If there is a feature that is important to you, the best way to get
  it implemented is to undertake the task yourself or sponsor a developer.
@@@ -46,8 -46,8 +46,8 @@@ Likely reason
  @itemize
  @item We are busy and haven't had time yet to read your report or
  investigate the issue.
 -@item You didn't follow @url{http://libav.org/bugreports.html}.
 -@item You didn't use git master.
 +@item You didn't follow @url{http://ffmpeg.org/bugreports.html}.
- @item You didn't use Subversion HEAD.
++@item You didn't use git HEAD.
  @item You reported a segmentation fault without gdb output.
  @item You describe a problem but not how to reproduce it.
  @item It's unclear if you use ffmpeg as command line tool or use
Simple merge
Simple merge
diff --cc version.sh
@@@ -1,13 -1,8 +1,10 @@@
  #!/bin/sh
  
- revision=$(cd "$1" && cat snapshot_version 2> /dev/null)
- test "$revision" && revision=SVN-r$revision
  # check for git short hash
 -revision=$(cd "$1" && git describe --always 2> /dev/null)
 -test "$revision" && revision=git-$revision
 +if ! test "$revision"; then
 +    revision=$(cd "$1" && git describe --tags --match N 2> /dev/null)
 +    test "$revision" && revision=git-$revision
 +fi
  
  # no revision number found
  test "$revision" || revision=UNKNOWN