Add lsp.o as a dependency for wmavoice. This fixes a compilation error when
authorJames Darnley <james.darnley@gmail.com>
Tue, 16 Feb 2010 14:33:13 +0000 (14:33 +0000)
committerRonald S. Bultje <rsbultje@gmail.com>
Tue, 16 Feb 2010 14:33:13 +0000 (14:33 +0000)
you disable lots of stuff (in particular other voice codecs) but leave
wmavoice enabled.

Patch by James Darnley <$firstname dot $lastname at gmail dot com>.

Originally committed as revision 21848 to svn://svn.ffmpeg.org/ffmpeg/trunk

libavcodec/Makefile

index 4e6f5a1..36d6618 100644 (file)
@@ -345,7 +345,8 @@ OBJS-$(CONFIG_WMAV2_DECODER)           += wmadec.o wma.o
 OBJS-$(CONFIG_WMAV2_ENCODER)           += wmaenc.o wma.o
 OBJS-$(CONFIG_WMAVOICE_DECODER)        += wmavoice.o \
                                           celp_math.o celp_filters.o \
-                                          acelp_vectors.o acelp_filters.o
+                                          acelp_vectors.o acelp_filters.o \
+                                          lsp.o
 OBJS-$(CONFIG_WMV2_DECODER)            += wmv2dec.o wmv2.o        \
                                           msmpeg4.o msmpeg4data.o \
                                           intrax8.o intrax8dsp.o