configure: Make the new qsv encoder depend on libmfx
authorLuca Barbato <lu_zero@gentoo.org>
Wed, 8 Jul 2015 22:18:19 +0000 (00:18 +0200)
committerLuca Barbato <lu_zero@gentoo.org>
Wed, 8 Jul 2015 22:20:27 +0000 (00:20 +0200)
Found-by: kropping
configure

index 9d66469..9aa5135 100755 (executable)
--- a/configure
+++ b/configure
@@ -1869,6 +1869,7 @@ hap_encoder_deps="libsnappy"
 hap_encoder_select="texturedspenc"
 hevc_decoder_select="bswapdsp cabac golomb videodsp"
 hevc_nvenc_encoder_deps="nvenc"
+hevc_qsv_encoder_deps="libmfx"
 hevc_qsv_encoder_select="qsvenc"
 huffyuv_decoder_select="bswapdsp huffyuvdsp"
 huffyuv_encoder_select="bswapdsp huffman huffyuvencdsp"
@@ -1908,6 +1909,7 @@ mpeg1video_decoder_select="error_resilience mpeg_er mpegvideo"
 mpeg1video_encoder_select="aandcttables mpegvideoenc"
 mpeg2video_decoder_select="error_resilience mpeg_er mpegvideo"
 mpeg2video_encoder_select="aandcttables mpegvideoenc"
+mpeg2_qsv_encoder_deps="libmfx"
 mpeg2_qsv_encoder_select="qsvenc"
 mpeg4_decoder_select="h263_decoder mpeg4video_parser"
 mpeg4_encoder_select="h263_encoder"