Only check for for libvpx decoder/encoder if libvpx is enabled.
authorDiego Biurrun <diego@biurrun.de>
Sun, 8 Aug 2010 08:51:15 +0000 (08:51 +0000)
committerDiego Biurrun <diego@biurrun.de>
Sun, 8 Aug 2010 08:51:15 +0000 (08:51 +0000)
Originally committed as revision 24744 to svn://svn.ffmpeg.org/ffmpeg/trunk

configure

index 1ab6798..5ec664c 100755 (executable)
--- a/configure
+++ b/configure
@@ -2697,10 +2697,11 @@ enabled libschroedinger && add_cflags $(pkg-config --cflags schroedinger-1.0) &&
 enabled libspeex   && require  libspeex speex/speex.h speex_decoder_init -lspeex
 enabled libtheora  && require  libtheora theora/theoraenc.h th_info_init -ltheoraenc -ltheoradec -logg
 enabled libvorbis  && require  libvorbis vorbis/vorbisenc.h vorbis_info_init -lvorbisenc -lvorbis -logg
-enabled_all libvpx libvpx_decoder && { check_lib2 "vpx/vpx_decoder.h vpx/vp8dx.h" vpx_codec_dec_init_ver -lvpx ||
-                            die "ERROR: libvpx decoder version must be >=0.9.1"; }
-enabled_all libvpx libvpx_encoder && { check_lib2 "vpx/vpx_encoder.h vpx/vp8cx.h" vpx_codec_enc_init_ver -lvpx ||
-                            die "ERROR: libvpx encoder version must be >=0.9.1"; }
+enabled libvpx     && {
+    enabled libvpx_decoder && { check_lib2 "vpx/vpx_decoder.h vpx/vp8dx.h" vpx_codec_dec_init_ver -lvpx ||
+                                die "ERROR: libvpx decoder version must be >=0.9.1"; }
+    enabled libvpx_encoder && { check_lib2 "vpx/vpx_encoder.h vpx/vp8cx.h" vpx_codec_enc_init_ver -lvpx ||
+                                die "ERROR: libvpx encoder version must be >=0.9.1"; } }
 enabled libx264    && require  libx264 x264.h x264_encoder_encode -lx264 &&
                       { check_cpp_condition x264.h "X264_BUILD >= 98" ||
                         die "ERROR: libx264 version must be >= 0.98."; }