Mention libav versioning in CVS policy section with a short explanation.
authorAlexander Strasser <eclipse7@gmx.net>
Mon, 26 Dec 2005 09:16:44 +0000 (09:16 +0000)
committerAlexander Strasser <eclipse7@gmx.net>
Mon, 26 Dec 2005 09:16:44 +0000 (09:16 +0000)
Originally committed as revision 4778 to svn://svn.ffmpeg.org/ffmpeg/trunk

doc/ffmpeg-doc.texi

index bb4cf04..3b03298 100644 (file)
@@ -1263,6 +1263,16 @@ please use av_log() instead.
     Never write to unallocated memory, never write over the end of arrays,
     always check values read from some untrusted source before using them
     as array index or other risky things.
+@item
+    Remember to check if you need to bump versions for the specific libav
+    parts (libavutil,libavcodec,libavformat) you are changing. You need
+    to change the version integer and the version string.
+    Incrementing the first component means no backward compatibility to
+    previous version (e.g. removal of a function).
+    Incrementing the second component means backward compatible change
+    (e.g. addition of a function).
+    Incrementing the third component means a noteworthy binary compatible
+    change (e.g. encoder bug fix that matters for the decoder).
 @end enumerate
 
 We think our rules are not too hard. If you have comments, contact us.