ffmpeg_opt: add proper deprecation guards to lowres code
authorJames Almer <jamrial@gmail.com>
Thu, 31 Aug 2017 01:31:35 +0000 (22:31 -0300)
committerJames Almer <jamrial@gmail.com>
Thu, 31 Aug 2017 01:45:00 +0000 (22:45 -0300)
Signed-off-by: James Almer <jamrial@gmail.com>
ffmpeg_opt.c

index f275f71..100fa76 100644 (file)
@@ -791,14 +791,16 @@ static void add_input_streams(OptionsContext *o, AVFormatContext *ic)
         case AVMEDIA_TYPE_VIDEO:
             if(!ist->dec)
                 ist->dec = avcodec_find_decoder(par->codec_id);
-#if FF_API_EMU_EDGE
+#if FF_API_LOWRES
             if (av_codec_get_lowres(st->codec)) {
                 av_codec_set_lowres(ist->dec_ctx, av_codec_get_lowres(st->codec));
                 ist->dec_ctx->width  = st->codec->width;
                 ist->dec_ctx->height = st->codec->height;
                 ist->dec_ctx->coded_width  = st->codec->coded_width;
                 ist->dec_ctx->coded_height = st->codec->coded_height;
+#if FF_API_EMU_EDGE
                 ist->dec_ctx->flags |= CODEC_FLAG_EMU_EDGE;
+#endif
             }
 #endif