configure: switch the libzvbi check to pkg-config
authorReino Wijnsma <rwijnsma@xs4all.nl>
Fri, 13 Oct 2017 22:52:27 +0000 (19:52 -0300)
committerJames Almer <jamrial@gmail.com>
Fri, 13 Oct 2017 23:22:44 +0000 (20:22 -0300)
The library has several dependencies that vary between systems.
Their pkg-config properly lists them all.

Signed-off-by: James Almer <jamrial@gmail.com>
configure

index 1bb6111..15f7e37 100755 (executable)
--- a/configure
+++ b/configure
@@ -6102,7 +6102,7 @@ enabled libxavs           && require libxavs "stdint.h xavs.h" xavs_encoder_enco
 enabled libxvid           && require libxvid xvid.h xvid_global -lxvidcore
 enabled libzimg           && require_pkg_config libzimg "zimg >= 2.3.0" zimg.h zimg_get_api_version
 enabled libzmq            && require_pkg_config libzmq libzmq zmq.h zmq_ctx_new
-enabled libzvbi           && require libzvbi libzvbi.h vbi_decoder_new -lzvbi &&
+enabled libzvbi           && require_pkg_config libzvbi zvbi-0.2 libzvbi.h vbi_decoder_new &&
                              { check_cpp_condition libzvbi.h "VBI_VERSION_MAJOR > 0 || VBI_VERSION_MINOR > 2 || VBI_VERSION_MINOR == 2 && VBI_VERSION_MICRO >= 28" ||
                                enabled gpl || die "ERROR: libzvbi requires version 0.2.28 or --enable-gpl."; }
 enabled libxml2           && require_pkg_config libxml2 libxml-2.0 libxml2/libxml/xmlversion.h xmlCheckVersion