avcodec: remove obsolete FF_API_FAST_MALLOC cruft
authorJames Almer <jamrial@gmail.com>
Sun, 14 Sep 2014 23:56:06 +0000 (20:56 -0300)
committerJames Almer <jamrial@gmail.com>
Sun, 5 Oct 2014 20:09:44 +0000 (17:09 -0300)
Signed-off-by: James Almer <jamrial@gmail.com>
libavcodec/avcodec.h
libavcodec/version.h

index 1484b61..7f985d4 100644 (file)
 
 #include "version.h"
 
-#if FF_API_FAST_MALLOC
-// to provide fast_*alloc
-#include "libavutil/mem.h"
-#endif
-
 /**
  * @defgroup libavc Encoding/Decoding Library
  * @{
index baf1b4d..0bbf453 100644 (file)
 #ifndef FF_API_MAX_BFRAMES
 #define FF_API_MAX_BFRAMES       (LIBAVCODEC_VERSION_MAJOR < 57)
 #endif
-#ifndef FF_API_FAST_MALLOC
-#define FF_API_FAST_MALLOC       (LIBAVCODEC_VERSION_MAJOR < 56)
-#endif
 #ifndef FF_API_NEG_LINESIZES
 #define FF_API_NEG_LINESIZES     (LIBAVCODEC_VERSION_MAJOR < 57)
 #endif