configure: jni no longer requires -ldl
authorAman Gupta <aman@tmm1.net>
Fri, 12 May 2017 18:34:24 +0000 (11:34 -0700)
committerMatthieu Bouron <matthieu.bouron@gmail.com>
Tue, 16 May 2017 10:25:13 +0000 (12:25 +0200)
This dependency was removed in 33d69a90085d30af8a292d9364b835a26565d6b9.

configure

index db9d7a1..73814ed 100755 (executable)
--- a/configure
+++ b/configure
@@ -5776,8 +5776,7 @@ enabled decklink          && { { check_header DeckLinkAPI.h || die "ERROR: DeckL
 enabled frei0r            && { check_header frei0r.h || die "ERROR: frei0r.h header not found"; }
 enabled gmp               && require gmp gmp.h mpz_export -lgmp
 enabled gnutls            && require_pkg_config gnutls gnutls/gnutls.h gnutls_global_init
-enabled jni               && { [ $target_os = "android" ] && check_header jni.h && enabled pthreads &&
-                               check_lib jni "dlfcn.h" dlopen -ldl || die "ERROR: jni not found"; }
+enabled jni               && { [ $target_os = "android" ] && check_header jni.h && enabled pthreads || die "ERROR: jni not found"; }
 enabled ladspa            && { check_header ladspa.h || die "ERROR: ladspa.h header not found"; }
 enabled libiec61883       && require libiec61883 libiec61883/iec61883.h iec61883_cmp_connect -lraw1394 -lavc1394 -lrom1394 -liec61883
 enabled libass            && require_pkg_config libass ass/ass.h ass_library_init