Merge commit 'bf8646274b3ea2d9a193edfdbd70a3bb5c6dd74f'
authorClément Bœsch <u@pkh.me>
Sat, 1 Apr 2017 10:41:42 +0000 (12:41 +0200)
committerClément Bœsch <u@pkh.me>
Sat, 1 Apr 2017 10:41:42 +0000 (12:41 +0200)
* commit 'bf8646274b3ea2d9a193edfdbd70a3bb5c6dd74f':
  doc: Add note about recent regression in AviSynth+

Merged-by: Clément Bœsch <u@pkh.me>
1  2 
doc/general.texi

@@@ -182,12 -177,42 +182,25 @@@ without needing to search for these hea
  For Windows, supported AviSynth variants are
  @url{http://avisynth.nl, AviSynth 2.6 RC1 or higher} for 32-bit builds and
  @url{http://avs-plus.net, AviSynth+ r1718 or higher} for 32-bit and 64-bit builds.
 -@url{https://github.com/AviSynth/AviSynthPlus, AviSynth+'s git repository}
 -provides a GNU-style Makefile which can install just the headers using
 -@code{make install PREFIX=/install/prefix}.
 +
 +For Linux and OS X, the supported AviSynth variant is
 +@url{https://github.com/avxsynth/avxsynth, AvxSynth}.
  
  @float NOTE
 -When using AviSynth+'s installed headers, the user must also pass
 -the avisynth/ include directory to @code{--extra-cflags}. For example,
 -if the PREFIX given to AviSynth+'s Makefile was /usr/i686-w64-mingw32,
 -then the correct command would be
 -@code{--extra-cflags="-I/usr/i686-w64-mingw32/include/avisynth"}.
 -@end float
 -
 -For Linux and OS X, the supported AviSynth variant is
 -@url{https://github.com/avxsynth/avxsynth, AvxSynth}.
 -@file{avxsynth_c.h} is installed as part of the normal
 -build routine, as illustrated on
 -@url{https://github.com/avxsynth/avxsynth/wiki/System-Setup, AvxSynth's wiki}.
 -(the instructions for compiling its prerequisites are outdated, as FFMS 2.18
 -or higher is now needed; the list of dependencies to be downloaded from the
 -repositories is still the same, though).
 -
 -@float NOTE
 -AviSynth and AvxSynth are loaded dynamically.  Distributors can build Libav
+ There is currently a regression in AviSynth+'s @code{capi.h} header as of
+ October 2016, which interferes with the ability for builds of Libav to use
+ MSVC-built binaries of AviSynth. Until this is resolved, you can make sure
+ a known good version is installed by checking out a version from before
+ the regression occurred:
+ @code{git clone -b MT git://github.com/AviSynth/AviSynthPlus.git @*
+ cd AviSynthPlus @*
+ git checkout -b oldheader b4f292b4dbfad149697fb65c6a037bb3810813f9 @*
+ make install PREFIX=/install/prefix}
+ @end float
+ @float NOTE
 +AviSynth and AvxSynth are loaded dynamically.  Distributors can build FFmpeg
  with @code{--enable-avisynth}, and the binaries will work regardless of the
  end user having AviSynth or AvxSynth installed - they'll only need to be
  installed to use AviSynth scripts (obviously).