Check for Decoder_Interface_init() instead of Speech_Decode_Frame_init() when
authorMartin Storsjö <martin@martin.st>
Wed, 15 Apr 2009 17:29:20 +0000 (17:29 +0000)
committerDiego Biurrun <diego@biurrun.de>
Wed, 15 Apr 2009 17:29:20 +0000 (17:29 +0000)
trying to enable libamrnb support. The latter function is actually used.
patch by Martin Storsjö, martin martin st

Originally committed as revision 18526 to svn://svn.ffmpeg.org/ffmpeg/trunk

configure

index 8488394..66d92de 100755 (executable)
--- a/configure
+++ b/configure
@@ -2036,7 +2036,7 @@ done
 
 # these are off by default, so fail if requested and not available
 enabled avisynth   && require2 vfw32 "windows.h vfw.h" AVIFileInit -lvfw32
-enabled libamr_nb  && require  libamrnb amrnb/interf_dec.h Speech_Decode_Frame_init -lamrnb -lm
+enabled libamr_nb  && require  libamrnb amrnb/interf_dec.h Decoder_Interface_init -lamrnb -lm
 enabled libamr_wb  && require  libamrwb amrwb/dec_if.h D_IF_init -lamrwb -lm
 enabled libdirac   && add_cflags $(pkg-config --cflags dirac) &&
                       require  libdirac libdirac_decoder/dirac_parser.h dirac_decoder_init -ldirac_decoder &&