require --enable-gpl for using the frei0r filter
authorStefano Sabatini <stefasab@gmail.com>
Wed, 12 Jun 2013 23:29:23 +0000 (01:29 +0200)
committerStefano Sabatini <stefasab@gmail.com>
Wed, 12 Jun 2013 23:40:24 +0000 (01:40 +0200)
frei0r license is GPL.

Based on a patch by Timothy Gu <timothygu99@gmail.com>.

See thread:
Subject: [FFmpeg-devel] [PATCH 1/2] LICENSE: Complete GPL'd external libraries list
Date: Thu,  6 Jun 2013 18:55:30 -0700

LICENSE
configure

diff --git a/LICENSE b/LICENSE
index a4b4006..28cb294 100644 (file)
--- a/LICENSE
+++ b/LICENSE
@@ -73,6 +73,7 @@ compatible libraries
 --------------------
 
 The following libraries are under GPL:
+    - frei0r
     - libcdio
     - libutvideo
     - libvidstab
index 103737d..ff35919 100755 (executable)
--- a/configure
+++ b/configure
@@ -3693,6 +3693,7 @@ die_license_disabled_gpl() {
     enabled $1 || { enabled $2 && die "$2 is incompatible with the gpl and --enable-$1 is not specified."; }
 }
 
+die_license_disabled gpl frei0r
 die_license_disabled gpl libcdio
 die_license_disabled gpl libutvideo
 die_license_disabled gpl libvidstab