avutil: reintroduce lls1 as the 52 ABI needs it
authorMichael Niedermayer <michaelni@gmx.at>
Fri, 15 Nov 2013 22:32:51 +0000 (23:32 +0100)
committerMichael Niedermayer <michaelni@gmx.at>
Sun, 17 Nov 2013 15:44:32 +0000 (16:44 +0100)
commitb382d09d29be90e0947295a70cdcbaa60b9030b8
treea4220d364f8dd0cc7b40adf5364d3abb787b3310
parentc3814ab654a993723b0e5f14cc252d68f233ad79
avutil: reintroduce lls1 as the 52 ABI needs it

lls1 taken from ff130d7

This is incompatible with libavcodec version
55.18.100 to 55.43.100 except 55.39.101
This incompatibility is caused by these libavcodec versions depending on
a libavutil 52 which is ABI incompatible with the previous ABI 52

you can avoid this incompatibility by upgrading your libavcodec so it
does no longer depend on the invalid ABI

See: 502ab21af0ca68f76d6112722c46d2f35c004053
See: cc6714bb16b1f0716ba43701d47273dbe9657b8b
See: 41578f70cf8aec8e7565fba1ca7e07f3dc46c3d2
See: Ticket3136
Tested-by: marillat
Signed-off-by: Michael Niedermayer <michaelni@gmx.at>
libavutil/Makefile
libavutil/lls1.c [new file with mode: 0644]
libavutil/lls1.h [new file with mode: 0644]
libavutil/version.h