configure: Use pkgconfig for VAAPI
authorMark Thompson <sw@jkqxz.net>
Tue, 18 Sep 2018 22:30:39 +0000 (23:30 +0100)
committerMark Thompson <sw@jkqxz.net>
Sun, 23 Sep 2018 13:42:33 +0000 (14:42 +0100)
commita00763be8861bcf499675b2af89d29e4e113cdc9
treee9a6c157804a633546e02e791fd05a65b77aaae0
parent009597ca33039b007f38c09a896cc14a38c8bcf0
configure: Use pkgconfig for VAAPI

Set the minimum version to 0.35.0 (libva 1.3.0) and remove redundant
configure tests.  This also allows the proprietary libmfx fork of libva,
which always shows the version number 0.99.0 (independent of the actual
version).
configure
libavcodec/vaapi_decode.c