lavf/tls_gnutls: fix warnings from version check
authorMoritz Barsnick <barsnick@gmx.net>
Tue, 26 Sep 2017 11:25:54 +0000 (13:25 +0200)
committerCarl Eugen Hoyos <ceffmpeg@gmail.com>
Tue, 26 Sep 2017 13:05:32 +0000 (15:05 +0200)
commit6bf48c4805cbb9754aa5a7bcb5f46df6bda95447
treec2701ec7101d8d281a41a2029dade6c8d174e43f
parent16c8a9feeab36239bb7cf5f87fa8cad4dc50ae8c
lavf/tls_gnutls: fix warnings from version check

The GnuTLS version is checked through the macro GNUTLS_VERSION_NUMBER,
but this wasn't introduced before 2.7.2. Building with older versions
of GnuTLS (using icc) warns:

src/libavformat/tls_gnutls.c(38): warning #193: zero used for undefined preprocessing identifier "GNUTLS_VERSION_NUMBER"
  #if HAVE_THREADS && GNUTLS_VERSION_NUMBER <= 0x020b00

This adds a fallback to the older, deprecated LIBGNUTLS_VERSION_NUMBER
macro.

Signed-off-by: Moritz Barsnick <barsnick@gmx.net>
libavformat/tls_gnutls.c