lsws/ppc/yuv2rgb_altivec: Replace vec_lvsl/vec_perm with vec_xl
authorChip Kerchner <ckerchne@linux.vnet.ibm.com>
Tue, 13 Aug 2019 00:21:24 +0000 (02:21 +0200)
committerCarl Eugen Hoyos <ceffmpeg@gmail.com>
Tue, 13 Aug 2019 00:21:24 +0000 (02:21 +0200)
commit3a557c5d88b7b15b5954ba2743febb055549b536
tree72973e2ddad4af2c87ed1088740088b6c7455fdd
parentfaa9cd312f02cec5f74658319d1119fcaa7f9088
lsws/ppc/yuv2rgb_altivec: Replace vec_lvsl/vec_perm with vec_xl

gcc 6.x and 7.x generate wrong code for little endian machines
for the vec_lvsl/vec_perm instruction combos in some cases.
The bug was fixed in version 8.x
If these instructions are replaced with vec_xl, the problem goes
away for all versions of the compilers.

Fixes ticket #7124.
libswscale/ppc/yuv2rgb_altivec.c