lavc/audiotoolboxenc: allow setting maxrate with pre-10.9 deployment targets
authorRodger Combs <rodger.combs@gmail.com>
Sun, 27 Mar 2016 17:17:25 +0000 (12:17 -0500)
committerRodger Combs <rodger.combs@gmail.com>
Sat, 2 Apr 2016 08:03:13 +0000 (03:03 -0500)
commit36770d876937db538179f6c87b57e3b5b609013c
treea308eccd27fd70d039223e0bad774412570fd52e
parent0667327f3fc7cad854712fcdbe13b7d15c791426
lavc/audiotoolboxenc: allow setting maxrate with pre-10.9 deployment targets

The build failure here is caused by the enum value not being defined, but
as long as we're on a newer SDK that has it, it's safe to use it even
when our deployment target is older. Setting the property will error, but
we're not failing on errors there.
libavcodec/audiotoolboxenc.c