libfdk-aacdec: Support building with the latest version of fdk-aac
authorMartin Storsjö <martin@martin.st>
Tue, 4 Nov 2014 08:22:05 +0000 (10:22 +0200)
committerMartin Storsjö <martin@martin.st>
Mon, 10 Nov 2014 07:43:57 +0000 (09:43 +0200)
commit28396d17ff1c1493b78d6eece484ffc27ed86d0d
tree21364464dfe78384039dd998c156642fc6290aae
parent09f25533a564eab743f258d168697a11122914c4
libfdk-aacdec: Support building with the latest version of fdk-aac

The latest fdk-aac code drop (from android 5.0) changed the channel
layout enums (changing the value of existing enum constants), and
renamed the option for downmixing.

The failsafe comparison between ctype and FF_ARRAY_ELEMS(channel_counts)
can trigger warnings (-Wtautological-constant-out-of-range-compare)
when building with the old FDK AAC releases, where it can't be
out of range with the enum values used there.

CC: libav-stable@libav.org
Signed-off-by: Martin Storsjö <martin@martin.st>
libavcodec/libfdk-aacdec.c