Merge commit 'f1b239ec8b38474d31f3bfea1f0b1693774fa432'
[ffmpeg.git] / configure
index e7c2d10..a4d1c59 100755 (executable)
--- a/configure
+++ b/configure
@@ -1304,7 +1304,6 @@ EXTERNAL_LIBRARY_LIST="
     bzlib
     crystalhd
     decklink
-    fontconfig
     frei0r
     gnutls
     iconv
@@ -1319,6 +1318,7 @@ EXTERNAL_LIBRARY_LIST="
     libfaac
     libfdk_aac
     libflite
+    libfontconfig
     libfreetype
     libgme
     libgsm
@@ -1445,6 +1445,7 @@ CONFIG_LIST="
     $LIBRARY_LIST
     $PROGRAM_LIST
     $SUBSYSTEM_LIST
+    fontconfig
     incompatible_libav_abi
     incompatible_fork_abi
     memalign_hack
@@ -4587,7 +4588,6 @@ enabled avisynth          && { { check_lib2 "windows.h" LoadLibrary; } ||
                                { check_lib2 "dlfcn.h" dlopen -ldl; } ||
                                die "ERROR: LoadLibrary/dlopen not found for avisynth"; }
 enabled decklink          && { check_header DeckLinkAPI.h || die "ERROR: DeckLinkAPI.h header not found"; }
-enabled fontconfig        && require_pkg_config fontconfig "fontconfig/fontconfig.h" FcInit
 enabled frei0r            && { check_header frei0r.h || die "ERROR: frei0r.h header not found"; }
 enabled gnutls            && require_pkg_config gnutls gnutls/gnutls.h gnutls_global_init
 enabled ladspa            && { check_header ladspa.h || die "ERROR: ladspa.h header not found"; }
@@ -4603,6 +4603,8 @@ enabled libfaac           && require2 libfaac "stdint.h faac.h" faacEncGetVersio
 enabled libfdk_aac        && require libfdk_aac fdk-aac/aacenc_lib.h aacEncOpen -lfdk-aac
 flite_libs="-lflite_cmu_time_awb -lflite_cmu_us_awb -lflite_cmu_us_kal -lflite_cmu_us_kal16 -lflite_cmu_us_rms -lflite_cmu_us_slt -lflite_usenglish -lflite_cmulex -lflite"
 enabled libflite          && require2 libflite "flite/flite.h" flite_init $flite_libs
+enabled fontconfig        && enable libfontconfig
+enabled libfontconfig     && require_pkg_config fontconfig "fontconfig/fontconfig.h" FcInit
 enabled libfreetype       && require_libfreetype
 enabled libgme            && require  libgme gme/gme.h gme_new_emu -lgme -lstdc++
 enabled libgsm            && { for gsm_hdr in "gsm.h" "gsm/gsm.h"; do