build: Warn that reconfiguration is necessary if version.h files changed
[ffmpeg.git] / Makefile
index 5aa2ab4..a7dcb6c 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -123,13 +123,14 @@ tools/cws2fws$(EXESUF): ELIBS = $(ZLIB)
 
 CONFIGURABLE_COMPONENTS =                                           \
     $(wildcard $(FFLIBS:%=$(SRC_PATH)/lib%/all*.c))                 \
+    $(wildcard $(FFLIBS:%=$(SRC_PATH)/lib%/version.h))              \
     $(SRC_PATH)/libavcodec/bitstream_filters.c                      \
     $(SRC_PATH)/libavformat/protocols.c                             \
 
 config.h: .config
 .config: $(CONFIGURABLE_COMPONENTS)
        @-tput bold 2>/dev/null
-       @-printf '\nWARNING: $(?F) newer than config.h, rerun configure\n\n'
+       @-printf '\nWARNING: $(?) newer than config.h, rerun configure\n\n'
        @-tput sgr0 2>/dev/null
 
 SUBDIR_VARS := CLEANFILES EXAMPLES FFLIBS HOSTPROGS TESTPROGS TOOLS      \