tests: drop bc dependency
[ffmpeg.git] / doc / platform.texi
1 \input texinfo @c -*- texinfo -*-
2
3 @settitle Platform Specific information
4 @titlepage
5 @center @titlefont{Platform Specific information}
6 @end titlepage
7
8 @top
9
10 @contents
11
12 @chapter Unix-like
13
14 Some parts of Libav cannot be built with version 2.15 of the GNU
15 assembler which is still provided by a few AMD64 distributions. To
16 make sure your compiler really uses the required version of gas
17 after a binutils upgrade, run:
18
19 @example
20 $(gcc -print-prog-name=as) --version
21 @end example
22
23 If not, then you should install a different compiler that has no
24 hard-coded path to gas. In the worst case pass @code{--disable-asm}
25 to configure.
26
27 @section Advanced linking configuration
28
29 If you compiled Libav libraries statically and you want to use them to
30 build your own shared library, you may need to force PIC support (with
31 @code{--enable-pic} during Libav configure) and add the following option
32 to your project LDFLAGS:
33
34 @example
35 -Wl,-Bsymbolic
36 @end example
37
38 If your target platform requires position independent binaries, you should
39 pass the correct linking flag (e.g. @code{-pie}) to @code{--extra-ldexeflags}.
40
41 @section BSD
42
43 BSD make will not build Libav, you need to install and use GNU Make
44 (@command{gmake}).
45
46 @section (Open)Solaris
47
48 GNU Make is required to build Libav, so you have to invoke (@command{gmake}),
49 standard Solaris Make will not work. When building with a non-c99 front-end
50 (gcc, generic suncc) add either @code{--extra-libs=/usr/lib/values-xpg6.o}
51 or @code{--extra-libs=/usr/lib/64/values-xpg6.o} to the configure options
52 since the libc is not c99-compliant by default. The probes performed by
53 configure may raise an exception leading to the death of configure itself
54 due to a bug in the system shell. Simply invoke a different shell such as
55 bash directly to work around this:
56
57 @example
58 bash ./configure
59 @end example
60
61 @anchor{Darwin}
62 @section Darwin (OS X, iPhone)
63
64 The toolchain provided with Xcode is sufficient to build the basic
65 unacelerated code.
66
67 OS X on PowerPC or ARM (iPhone) requires a preprocessor from
68 @url{git://git.libav.org/gas-preprocessor.git} to build the optimized
69 assembly functions. Put the Perl script somewhere
70 in your PATH, Libav's configure will pick it up automatically.
71
72 OS X on AMD64 and x86 requires @command{yasm} to build most of the
73 optimized assembly functions @url{http://mxcl.github.com/homebrew/, Homebrew},
74 @url{http://www.gentoo.org/proj/en/gentoo-alt/prefix/bootstrap-macos.xml, Gentoo Prefix}
75 or @url{http://www.macports.org, MacPorts} can easily provide it.
76
77
78 @chapter DOS
79
80 Using a cross-compiler is preferred for various reasons.
81 @url{http://www.delorie.com/howto/djgpp/linux-x-djgpp.html}
82
83
84 @chapter OS/2
85
86 For information about compiling Libav on OS/2 see
87 @url{http://www.edm2.com/index.php/FFmpeg}.
88
89
90 @chapter Windows
91
92 @section Native Windows compilation using MinGW or MinGW-w64
93
94 Libav can be built to run natively on Windows using the MinGW-w64
95 toolchain. Install the latest versions of MSYS2 and MinGW-w64 from
96 @url{http://msys2.github.io/} and/or @url{http://mingw-w64.sourceforge.net/}.
97 You can find detailed installation instructions in the download section and
98 the FAQ.
99
100 Notes:
101
102 @itemize
103
104 @item Building natively using MSYS2 can be sped up by disabling implicit rules
105 in the Makefile by calling @code{make -r} instead of plain @code{make}. This
106 speed up is close to non-existent for normal one-off builds and is only
107 noticeable when running make for a second time (for example during
108 @code{make install}).
109
110 @item In order to compile AVplay, you must have the MinGW development library
111 of @uref{http://www.libsdl.org/, SDL} and @code{pkg-config} installed.
112
113 @item By using @code{./configure --enable-shared} when configuring Libav,
114 you can build all libraries as DLLs.
115
116 @end itemize
117
118 @section Microsoft Visual C++ or Intel C++ Compiler for Windows
119
120 Libav can be built with MSVC 2012 or earlier using a C99-to-C89 conversion utility
121 and wrapper, or with MSVC 2013 and ICL natively.
122
123 You will need the following prerequisites:
124
125 @itemize
126 @item @uref{https://github.com/libav/c99-to-c89/, C99-to-C89 Converter & Wrapper}
127 (if using MSVC 2012 or earlier)
128 @item @uref{http://code.google.com/p/msinttypes/, msinttypes}
129 (if using MSVC 2012 or earlier)
130 @item @uref{http://msys2.github.io/, MSYS2}
131 @item @uref{http://yasm.tortall.net/, YASM}
132 (Also available via MSYS2's package manager.)
133 @end itemize
134
135 To set up a proper environment in MSYS2, you need to run @code{msys_shell.bat} from
136 the Visual Studio or Intel Compiler command prompt.
137
138 Place @code{yasm.exe} somewhere in your @code{PATH}. If using MSVC 2012 or
139 earlier, place @code{c99wrap.exe} and @code{c99conv.exe} somewhere in your
140 @code{PATH} as well.
141
142 Next, make sure any other headers and libs you want to use, such as zlib, are
143 located in a spot that the compiler can see. Do so by modifying the @code{LIB}
144 and @code{INCLUDE} environment variables to include the @strong{Windows-style}
145 paths to these directories. Alternatively, you can try and use the
146 @code{--extra-cflags}/@code{--extra-ldflags} configure options. If using MSVC
147 2012 or earlier, place @code{inttypes.h} somewhere the compiler can see too.
148
149 Finally, run:
150
151 @example
152 For MSVC:
153 ./configure --toolchain=msvc
154
155 For ICL:
156 ./configure --toolchain=icl
157
158 make
159 make install
160 @end example
161
162 If you wish to compile shared libraries, add @code{--enable-shared} to your
163 configure options. Note that due to the way MSVC and ICL handle DLL imports and
164 exports, you cannot compile static and shared libraries at the same time, and
165 enabling shared libraries will automatically disable the static ones.
166
167 Notes:
168
169 @itemize
170
171 @item It is possible that coreutils' @code{link.exe} conflicts with MSVC's linker.
172 You can find out by running @code{which link} to see which @code{link.exe} you
173 are using. If it is located at @code{/bin/link.exe}, then you have the wrong one
174 in your @code{PATH}. Either move or remove that copy, or make sure MSVC's
175 @code{link.exe} takes precedence in your @code{PATH} over coreutils'.
176
177 @item If you wish to build with zlib support, you will have to grab a compatible
178 zlib binary from somewhere, with an MSVC import lib, or if you wish to link
179 statically, you can follow the instructions below to build a compatible
180 @code{zlib.lib} with MSVC. Regardless of which method you use, you must still
181 follow step 3, or compilation will fail.
182 @enumerate
183 @item Grab the @uref{http://zlib.net/, zlib sources}.
184 @item Edit @code{win32/Makefile.msc} so that it uses -MT instead of -MD, since
185 this is how Libav is built as well.
186 @item Edit @code{zconf.h} and remove its inclusion of @code{unistd.h}. This gets
187 erroneously included when building Libav.
188 @item Run @code{nmake -f win32/Makefile.msc}.
189 @item Move @code{zlib.lib}, @code{zconf.h}, and @code{zlib.h} to somewhere MSVC
190 can see.
191 @end enumerate
192
193 @item Libav has been tested with the following on i686 and x86_64:
194 @itemize
195 @item Visual Studio 2010 Pro and Express
196 @item Visual Studio 2012 Pro and Express
197 @item Visual Studio 2013 Pro and Express
198 @item Intel Composer XE 2013
199 @item Intel Composer XE 2013 SP1
200 @end itemize
201 Anything else is not officially supported.
202
203 @end itemize
204
205 @subsection Linking to Libav with Microsoft Visual C++
206
207 If you plan to link with MSVC-built static libraries, you will need
208 to make sure you have @code{Runtime Library} set to
209 @code{Multi-threaded (/MT)} in your project's settings.
210
211 You will need to define @code{inline} to something MSVC understands:
212 @example
213 #define inline __inline
214 @end example
215
216 Also note, that as stated in @strong{Microsoft Visual C++}, you will need
217 an MSVC-compatible @uref{http://code.google.com/p/msinttypes/, inttypes.h}.
218
219 If you plan on using import libraries created by dlltool, you must
220 set @code{References} to @code{No (/OPT:NOREF)} under the linker optimization
221 settings, otherwise the resulting binaries will fail during runtime.
222 This is not required when using import libraries generated by @code{lib.exe}.
223 This issue is reported upstream at
224 @url{http://sourceware.org/bugzilla/show_bug.cgi?id=12633}.
225
226 To create import libraries that work with the @code{/OPT:REF} option
227 (which is enabled by default in Release mode), follow these steps:
228
229 @enumerate
230
231 @item Open the @emph{Visual Studio Command Prompt}.
232
233 Alternatively, in a normal command line prompt, call @file{vcvars32.bat}
234 which sets up the environment variables for the Visual C++ tools
235 (the standard location for this file is something like
236 @file{C:\Program Files (x86_\Microsoft Visual Studio 10.0\VC\bin\vcvars32.bat}).
237
238 @item Enter the @file{bin} directory where the created LIB and DLL files
239 are stored.
240
241 @item Generate new import libraries with @command{lib.exe}:
242
243 @example
244 lib /machine:i386 /def:..\lib\foo-version.def  /out:foo.lib
245 @end example
246
247 Replace @code{foo-version} and @code{foo} with the respective library names.
248
249 @end enumerate
250
251 @anchor{Cross compilation for Windows with Linux}
252 @section Cross compilation for Windows with Linux
253
254 You must use the MinGW cross compilation tools available at
255 @url{http://www.mingw.org/}.
256
257 Then configure Libav with the following options:
258 @example
259 ./configure --target-os=mingw32 --cross-prefix=i386-mingw32msvc-
260 @end example
261 (you can change the cross-prefix according to the prefix chosen for the
262 MinGW tools).
263
264 Then you can easily test Libav with @uref{http://www.winehq.com/, Wine}.
265
266 @section Compilation under Cygwin
267
268 Please use Cygwin 1.7.x as the obsolete 1.5.x Cygwin versions lack
269 llrint() in its C library.
270
271 Install your Cygwin with all the "Base" packages, plus the
272 following "Devel" ones:
273 @example
274 binutils, gcc4-core, make, git, mingw-runtime, texi2html
275 @end example
276
277 In order to run FATE you will also need the following "Utils" packages:
278 @example
279 diffutils
280 @end example
281
282 If you want to build Libav with additional libraries, download Cygwin
283 "Devel" packages for Ogg and Vorbis from any Cygwin packages repository:
284 @example
285 libogg-devel, libvorbis-devel
286 @end example
287
288 These library packages are only available from
289 @uref{http://sourceware.org/cygwinports/, Cygwin Ports}:
290
291 @example
292 yasm, libSDL-devel, libfaac-devel, libgsm-devel, libmp3lame-devel,
293 libschroedinger1.0-devel, speex-devel, libtheora-devel, libxvidcore-devel
294 @end example
295
296 The recommendation for x264 is to build it from source, as it evolves too
297 quickly for Cygwin Ports to be up to date.
298
299 @section Crosscompilation for Windows under Cygwin
300
301 With Cygwin you can create Windows binaries that do not need the cygwin1.dll.
302
303 Just install your Cygwin as explained before, plus these additional
304 "Devel" packages:
305 @example
306 gcc-mingw-core, mingw-runtime, mingw-zlib
307 @end example
308
309 and add some special flags to your configure invocation.
310
311 For a static build run
312 @example
313 ./configure --target-os=mingw32 --extra-cflags=-mno-cygwin --extra-libs=-mno-cygwin
314 @end example
315
316 and for a build with shared libraries
317 @example
318 ./configure --target-os=mingw32 --enable-shared --disable-static --extra-cflags=-mno-cygwin --extra-libs=-mno-cygwin
319 @end example
320
321 @chapter Plan 9
322
323 The native @uref{http://plan9.bell-labs.com/plan9/, Plan 9} compiler
324 does not implement all the C99 features needed by Libav so the gcc
325 port must be used.  Furthermore, a few items missing from the C
326 library and shell environment need to be fixed.
327
328 @itemize
329
330 @item GNU awk, grep, make, and sed
331
332 Working packages of these tools can be found at
333 @uref{http://code.google.com/p/ports2plan9/downloads/list, ports2plan9}.
334 They can be installed with @uref{http://9front.org/, 9front's} @code{pkg}
335 utility by setting @code{pkgpath} to
336 @code{http://ports2plan9.googlecode.com/files/}.
337
338 @item Missing/broken @code{head} and @code{printf} commands
339
340 Replacements adequate for building Libav can be found in the
341 @code{compat/plan9} directory.  Place these somewhere they will be
342 found by the shell.  These are not full implementations of the
343 commands and are @emph{not} suitable for general use.
344
345 @item Missing C99 @code{stdint.h} and @code{inttypes.h}
346
347 Replacement headers are available from
348 @url{http://code.google.com/p/plan9front/issues/detail?id=152}.
349
350 @item Missing or non-standard library functions
351
352 Some functions in the C library are missing or incomplete.  The
353 @code{@uref{http://ports2plan9.googlecode.com/files/gcc-apelibs-1207.tbz,
354 gcc-apelibs-1207}} package from
355 @uref{http://code.google.com/p/ports2plan9/downloads/list, ports2plan9}
356 includes an updated C library, but installing the full package gives
357 unusable executables.  Instead, keep the files from @code{gccbin.tgz}
358 under @code{/386/lib/gnu}.  From the @code{libc.a} archive in the
359 @code{gcc-apelibs-1207} package, extract the following object files and
360 turn them into a library:
361
362 @itemize
363 @item @code{strerror.o}
364 @item @code{strtoll.o}
365 @item @code{snprintf.o}
366 @item @code{vsnprintf.o}
367 @item @code{vfprintf.o}
368 @item @code{_IO_getc.o}
369 @item @code{_IO_putc.o}
370 @end itemize
371
372 Use the @code{--extra-libs} option of @code{configure} to inform the
373 build system of this library.
374
375 @item FPU exceptions enabled by default
376
377 Unlike most other systems, Plan 9 enables FPU exceptions by default.
378 These must be disabled before calling any Libav functions.  While the
379 included tools will do this automatically, other users of the
380 libraries must do it themselves.
381
382 @end itemize
383
384 @bye