LICENSE: Remove a file that does not exist anymore.
[ffmpeg.git] / LICENSE.md
1 # License
2
3 Most files in FFmpeg are under the GNU Lesser General Public License version 2.1
4 or later (LGPL v2.1+). Read the file `COPYING.LGPLv2.1` for details. Some other
5 files have MIT/X11/BSD-style licenses. In combination the LGPL v2.1+ applies to
6 FFmpeg.
7
8 Some optional parts of FFmpeg are licensed under the GNU General Public License
9 version 2 or later (GPL v2+). See the file `COPYING.GPLv2` for details. None of
10 these parts are used by default, you have to explicitly pass `--enable-gpl` to
11 configure to activate them. In this case, FFmpeg's license changes to GPL v2+.
12
13 Specifically, the GPL parts of FFmpeg are:
14
15 - libpostproc
16 - optional x86 optimization in the files
17     - `libavcodec/x86/flac_dsp_gpl.asm`
18     - `libavcodec/x86/idct_mmx.c`
19     - `libavfilter/x86/vf_removegrain.asm`
20 - the following building and testing tools
21     - `compat/solaris/make_sunver.pl`
22     - `doc/t2h.pm`
23     - `doc/texi2pod.pl`
24     - `libswresample/tests/swresample.c`
25     - `tests/checkasm/*`
26     - `tests/tiny_ssim.c`
27 - the following filters in libavfilter:
28     - `vf_blackframe.c`
29     - `vf_boxblur.c`
30     - `vf_colormatrix.c`
31     - `vf_cover_rect.c`
32     - `vf_cropdetect.c`
33     - `vf_delogo.c`
34     - `vf_eq.c`
35     - `vf_find_rect.c`
36     - `vf_fspp.c`
37     - `vf_geq.c`
38     - `vf_histeq.c`
39     - `vf_hqdn3d.c`
40     - `vf_kerndeint.c`
41     - `vf_mcdeint.c`
42     - `vf_mpdecimate.c`
43     - `vf_owdenoise.c`
44     - `vf_perspective.c`
45     - `vf_phase.c`
46     - `vf_pp.c`
47     - `vf_pp7.c`
48     - `vf_pullup.c`
49     - `vf_repeatfields.c`
50     - `vf_sab.c`
51     - `vf_smartblur.c`
52     - `vf_spp.c`
53     - `vf_stereo3d.c`
54     - `vf_super2xsai.c`
55     - `vf_tinterlace.c`
56     - `vf_uspp.c`
57     - `vsrc_mptestsrc.c`
58
59 Should you, for whatever reason, prefer to use version 3 of the (L)GPL, then
60 the configure parameter `--enable-version3` will activate this licensing option
61 for you. Read the file `COPYING.LGPLv3` or, if you have enabled GPL parts,
62 `COPYING.GPLv3` to learn the exact legal terms that apply in this case.
63
64 There are a handful of files under other licensing terms, namely:
65
66 * The files `libavcodec/jfdctfst.c`, `libavcodec/jfdctint_template.c` and
67   `libavcodec/jrevdct.c` are taken from libjpeg, see the top of the files for
68   licensing details. Specifically note that you must credit the IJG in the
69   documentation accompanying your program if you only distribute executables.
70   You must also indicate any changes including additions and deletions to
71   those three files in the documentation.
72 * `tests/reference.pnm` is under the expat license.
73
74
75 ## External libraries
76
77 FFmpeg can be combined with a number of external libraries, which sometimes
78 affect the licensing of binaries resulting from the combination.
79
80 ### Compatible libraries
81
82 The following libraries are under GPL:
83 - frei0r
84 - libcdio
85 - librubberband
86 - libvidstab
87 - libx264
88 - libx265
89 - libxavs
90 - libxvid
91
92 When combining them with FFmpeg, FFmpeg needs to be licensed as GPL as well by
93 passing `--enable-gpl` to configure.
94
95 The OpenCORE and VisualOn libraries are under the Apache License 2.0. That
96 license is incompatible with the LGPL v2.1 and the GPL v2, but not with
97 version 3 of those licenses. So to combine these libraries with FFmpeg, the
98 license version needs to be upgraded by passing `--enable-version3` to configure.
99
100 ### Incompatible libraries
101
102 There are certain libraries you can combine with FFmpeg whose licenses are not
103 compatible with the GPL and/or the LGPL. If you wish to enable these
104 libraries, even in circumstances that their license may be incompatible, pass
105 `--enable-nonfree` to configure. This will cause the resulting binary to be
106 unredistributable.
107
108 The Fraunhofer FDK AAC and OpenSSL libraries are under licenses which are
109 incompatible with the GPLv2 and v3. To the best of our knowledge, they are
110 compatible with the LGPL.