configure: bump year
[ffmpeg.git] / LICENSE.md
1 # License
2
3 Most files in FFmpeg are under the GNU Lesser General Public License version 2.1
4 or later (LGPL v2.1+). Read the file `COPYING.LGPLv2.1` for details. Some other
5 files have MIT/X11/BSD-style licenses. In combination the LGPL v2.1+ applies to
6 FFmpeg.
7
8 Some optional parts of FFmpeg are licensed under the GNU General Public License
9 version 2 or later (GPL v2+). See the file `COPYING.GPLv2` for details. None of
10 these parts are used by default, you have to explicitly pass `--enable-gpl` to
11 configure to activate them. In this case, FFmpeg's license changes to GPL v2+.
12
13 Specifically, the GPL parts of FFmpeg are:
14
15 - libpostproc
16 - optional x86 optimization in the files
17     - `libavcodec/x86/flac_dsp_gpl.asm`
18     - `libavcodec/x86/idct_mmx.c`
19     - `libavfilter/x86/vf_removegrain.asm`
20 - the following building and testing tools
21     - `compat/solaris/make_sunver.pl`
22     - `doc/t2h.pm`
23     - `doc/texi2pod.pl`
24     - `libswresample/swresample-test.c`
25     - `tests/checkasm/*`
26     - `tests/tiny_ssim.c`
27 - the following filters in libavfilter:
28     - `vf_blackframe.c`
29     - `vf_boxblur.c`
30     - `vf_colormatrix.c`
31     - `vf_cover_rect.c`
32     - `vf_cropdetect.c`
33     - `vf_delogo.c`
34     - `vf_eq.c`
35     - `vf_find_rect.c`
36     - `vf_fspp.c`
37     - `vf_geq.c`
38     - `vf_histeq.c`
39     - `vf_hqdn3d.c`
40     - `vf_interlace.c`
41     - `vf_kerndeint.c`
42     - `vf_mcdeint.c`
43     - `vf_mpdecimate.c`
44     - `vf_owdenoise.c`
45     - `vf_perspective.c`
46     - `vf_phase.c`
47     - `vf_pp.c`
48     - `vf_pp7.c`
49     - `vf_pullup.c`
50     - `vf_repeatfields.c`
51     - `vf_sab.c`
52     - `vf_smartblur.c`
53     - `vf_spp.c`
54     - `vf_stereo3d.c`
55     - `vf_super2xsai.c`
56     - `vf_tinterlace.c`
57     - `vf_uspp.c`
58     - `vsrc_mptestsrc.c`
59
60 Should you, for whatever reason, prefer to use version 3 of the (L)GPL, then
61 the configure parameter `--enable-version3` will activate this licensing option
62 for you. Read the file `COPYING.LGPLv3` or, if you have enabled GPL parts,
63 `COPYING.GPLv3` to learn the exact legal terms that apply in this case.
64
65 There are a handful of files under other licensing terms, namely:
66
67 * The files `libavcodec/jfdctfst.c`, `libavcodec/jfdctint_template.c` and
68   `libavcodec/jrevdct.c` are taken from libjpeg, see the top of the files for
69   licensing details. Specifically note that you must credit the IJG in the
70   documentation accompanying your program if you only distribute executables.
71   You must also indicate any changes including additions and deletions to
72   those three files in the documentation.
73 * `tests/reference.pnm` is under the expat license.
74
75
76 ## External libraries
77
78 FFmpeg can be combined with a number of external libraries, which sometimes
79 affect the licensing of binaries resulting from the combination.
80
81 ### Compatible libraries
82
83 The following libraries are under GPL:
84 - frei0r
85 - libcdio
86 - librubberband
87 - libvidstab
88 - libx264
89 - libx265
90 - libxavs
91 - libxvid
92
93 When combining them with FFmpeg, FFmpeg needs to be licensed as GPL as well by
94 passing `--enable-gpl` to configure.
95
96 The OpenCORE and VisualOn libraries are under the Apache License 2.0. That
97 license is incompatible with the LGPL v2.1 and the GPL v2, but not with
98 version 3 of those licenses. So to combine these libraries with FFmpeg, the
99 license version needs to be upgraded by passing `--enable-version3` to configure.
100
101 ### Incompatible libraries
102
103 There are certain libraries you can combine with FFmpeg whose licenses are not
104 compatible with the GPL and/or the LGPL. If you wish to enable these
105 libraries, even in circumstances that their license may be incompatible, pass
106 `--enable-nonfree` to configure. But note that if you enable any of these
107 libraries the resulting binary will be under a complex license mix that is
108 more restrictive than the LGPL and that may result in additional obligations.
109 It is possible that these restrictions cause the resulting binary to be
110 unredistributable.
111
112 The Fraunhofer FDK AAC and OpenSSL libraries are under licenses which are
113 incompatible with the GPLv2 and v3. To the best of our knowledge, they are
114 compatible with the LGPL.
115
116 The NVENC library, while its header file is licensed under the compatible MIT
117 license, requires a proprietary binary blob at run time, and is deemed to be
118 incompatible with the GPL. We are not certain if it is compatible with the
119 LGPL, but we require `--enable-nonfree` even with LGPL configurations in case
120 it is not.