avcodec: Extend fft to size 2^17
[ffmpeg.git] / LICENSE.md
1 # License
2
3 Most files in FFmpeg are under the GNU Lesser General Public License version 2.1
4 or later (LGPL v2.1+). Read the file `COPYING.LGPLv2.1` for details. Some other
5 files have MIT/X11/BSD-style licenses. In combination the LGPL v2.1+ applies to
6 FFmpeg.
7
8 Some optional parts of FFmpeg are licensed under the GNU General Public License
9 version 2 or later (GPL v2+). See the file `COPYING.GPLv2` for details. None of
10 these parts are used by default, you have to explicitly pass `--enable-gpl` to
11 configure to activate them. In this case, FFmpeg's license changes to GPL v2+.
12
13 Specifically, the GPL parts of FFmpeg are:
14
15 - libpostproc
16 - optional x86 optimization in the files
17     - `libavcodec/x86/flac_dsp_gpl.asm`
18     - `libavcodec/x86/idct_mmx.c`
19     - `libavfilter/x86/vf_removegrain.asm`
20 - libutvideo encoding/decoding wrappers in `libavcodec/libutvideo*.cpp`
21 - the X11 grabber in `libavdevice/x11grab.c`
22 - the following building and testing tools
23     - `compat/solaris/make_sunver.pl`
24     - `doc/t2h.pm`
25     - `doc/texi2pod.pl`
26     - `libswresample/swresample-test.c`
27     - `tests/checkasm/*`
28     - `tests/tiny_ssim.c`
29 - the following filters in libavfilter:
30     - `f_ebur128.c`
31     - `vf_blackframe.c`
32     - `vf_boxblur.c`
33     - `vf_colormatrix.c`
34     - `vf_cover_rect.c`
35     - `vf_cropdetect.c`
36     - `vf_delogo.c`
37     - `vf_eq.c`
38     - `vf_find_rect.c`
39     - `vf_fspp.c`
40     - `vf_geq.c`
41     - `vf_histeq.c`
42     - `vf_hqdn3d.c`
43     - `vf_interlace.c`
44     - `vf_kerndeint.c`
45     - `vf_mcdeint.c`
46     - `vf_mpdecimate.c`
47     - `vf_owdenoise.c`
48     - `vf_perspective.c`
49     - `vf_phase.c`
50     - `vf_pp.c`
51     - `vf_pp7.c`
52     - `vf_pullup.c`
53     - `vf_repeatfields.c`
54     - `vf_sab.c`
55     - `vf_smartblur.c`
56     - `vf_spp.c`
57     - `vf_stereo3d.c`
58     - `vf_super2xsai.c`
59     - `vf_tinterlace.c`
60     - `vf_uspp.c`
61     - `vsrc_mptestsrc.c`
62
63 Should you, for whatever reason, prefer to use version 3 of the (L)GPL, then
64 the configure parameter `--enable-version3` will activate this licensing option
65 for you. Read the file `COPYING.LGPLv3` or, if you have enabled GPL parts,
66 `COPYING.GPLv3` to learn the exact legal terms that apply in this case.
67
68 There are a handful of files under other licensing terms, namely:
69
70 * The files `libavcodec/jfdctfst.c`, `libavcodec/jfdctint_template.c` and
71   `libavcodec/jrevdct.c` are taken from libjpeg, see the top of the files for
72   licensing details. Specifically note that you must credit the IJG in the
73   documentation accompanying your program if you only distribute executables.
74   You must also indicate any changes including additions and deletions to
75   those three files in the documentation.
76 * `tests/reference.pnm` is under the expat license.
77
78
79 ## External libraries
80
81 FFmpeg can be combined with a number of external libraries, which sometimes
82 affect the licensing of binaries resulting from the combination.
83
84 ### Compatible libraries
85
86 The following libraries are under GPL:
87 - frei0r
88 - libcdio
89 - librubberband
90 - libutvideo
91 - libvidstab
92 - libx264
93 - libx265
94 - libxavs
95 - libxvid
96
97 When combining them with FFmpeg, FFmpeg needs to be licensed as GPL as well by
98 passing `--enable-gpl` to configure.
99
100 The OpenCORE and VisualOn libraries are under the Apache License 2.0. That
101 license is incompatible with the LGPL v2.1 and the GPL v2, but not with
102 version 3 of those licenses. So to combine these libraries with FFmpeg, the
103 license version needs to be upgraded by passing `--enable-version3` to configure.
104
105 ### Incompatible libraries
106
107 There are certain libraries you can combine with FFmpeg whose licenses are not
108 compatible with the GPL and/or the LGPL. If you wish to enable these
109 libraries, even in circumstances that their license may be incompatible, pass
110 `--enable-nonfree` to configure. But note that if you enable any of these
111 libraries the resulting binary will be under a complex license mix that is
112 more restrictive than the LGPL and that may result in additional obligations.
113 It is possible that these restrictions cause the resulting binary to be
114 unredistributable.
115
116 The Fraunhofer FDK AAC and OpenSSL libraries are under licenses which are
117 incompatible with the GPLv2 and v3. To the best of our knowledge, they are
118 compatible with the LGPL.
119
120 The FAAC library is incompatible with all versions of GPL and LGPL.
121
122 The NVENC library, while its header file is licensed under the compatible MIT
123 license, requires a proprietary binary blob at run time, and is deemed to be
124 incompatible with the GPL. We are not certain if it is compatible with the
125 LGPL, but we require `--enable-nonfree` even with LGPL configurations in case
126 it is not.